The new TBS Powercube Colibri FC (v1.2, V2.0 or above) is not compatible with older V1.0 PDB's out of the box. It will require a small 1 min modification. 

All that needs to be done is to cut off one pin on the TBS Powercube PDB(non-v2.0)

Unless you are using an old flight control (V1.0, V1.1), you will not need to make any changes. 

Owners of PowerCube FPVision layers or PDB V2.0 will not need to make any modifications at all, no matter what FC version is used.